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CorelDRAW Tutorials 

Top 5 Photo Fixes using Corel PHOTO-PAINT 

By Steve Bain 

Whether you're out snapping photos with your digital camera or just scanning old family album 
favorites to disc, you're bound to end up with little anomalies that you wish you could fix quickly. In 
this tutorial, we'll show you five common problems with scanned images and digital camera photos, 

and the techniques you can use to fix them using the tools and filters in Corel PHOTO-PAINT . 

Removing Red Eye 
Red eye is the red glow most often seen in photos taken using an in-camera flash where the subject is 
directly facing the camera lens. The bright flash illuminates blood vessels at the back of the eye with 
ghoulish results. The problem is so unsavory that there are literally dozens of digital techniques to 

eliminate it. Thankfully, Corel PHOTO-PAINT has an elegant solution using a dedicated tool. You'll find 
it in the Toolbox with the Clone Tool and the Touch-up Brush. 

 

The Red Eye Removal Tool enables you to eradicate red eye often with a single click to the affected 

eye. It works by replacing the range of red colors that are commonly found in the red eye 
phenomenon with darker colors without affecting the surrounding iris color. It features a Size control 

and a Tolerance option to adjust the sensitivity and range of the colors it replaces. 

To rid your digital photo of the demon red eye, follow these steps: 

1. Select the Red Eye Removal Tool and use Property Bar options (shown next) to set the 
diameter of the brush to roughly the size of the affected pupil.  

 

2. Click once to remove the unwanted red color in each pupil. That's it - you're done.  
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In our example photo (shown below), one click using the default settings restored the original eye 
color. 

 

Scanned Dust and Lint 
Although you likely won't see these in digital photos, you may notice after scanning your photos that 

they include tiny white or dark colored specks. This may mean that you've inadvertently recorded 
minuscule particles along with your photos. You can always clean the scanner and re-scan your 
photos, but you just end up with a less dusty photo. You may be faced with fixing the next most 

common problem - removing dust and lint. 

Dust often appears as tiny dark or white spots on your scanned images, while lint usually shows up as 

out-of-focus threads or hairs. Because of their size and shape difference, you may need to use 
different strategies to eliminate dust and lint. 

With Corel PHOTO-PAINT, you can choose between two different dust-removal techniques - depending 
on how widespread your dust problem is. The first method involves using the Dust and Scratch filter, 
which enables you to automatically eliminate small marks on your photo. To use this filter, choose 

Image > Correction > Dust and Scratch. As shown below, there are just two options available in the 
dialog: Threshold and Radius. 

 

The Threshold setting changes pixel contrast, which can reduce or eliminate visible dust particles and 
other tiny marks. The Radius setting enables you to control the number of pixels involved in the 

smoothing effect that is applied. The default Threshold setting of 64 and Radius setting of 2 will fix 

most common dust problems. If your dust problem is more serious, you can lower the Threshold and 

increase the Radius value slightly. Keep in mind that changing the settings will increase the intensity 
of the effect and could degrade the quality of your photo. 
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Select only what you need to correct using one of Corel PHOTO-PAINT's selection tools. That way, only 
non-masked areas will be affected. If no selection is made, the entire photo will be affected by the 

filter settings that you apply. 

In our dusty example below, tiny white particles visible on the darker areas were quickly removed 
using a Threshold setting of 30 and a Radius setting of 2. 

 

As an alternative to the Dust and Scratch filter, you can also use the Touch-up Brush to remove dust. 
The Touch-up Brush applies smoothing and reduces pixel contrast, which gives you a more interactive 

and selective way of reducing dust and other marks. You'll find it in the Toolbox grouped with the Red 
Eye Removal Tool and the Clone Tool (as shown below). 

 

When using the Touch-up Brush Tool on dust, use the Property Bar to adjust your brush for a 
feathered edge with a Strength setting of Very Low (as shown below). That way you can remove the 

dust gradually apply the smoothing effect in steps without altering clean areas. 
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For lint problems or even in instances where your photo has a nasty scratch, the Clone Tool is your 
best choice. The Clone Tool enables you to copy specific pixels from one area to another interactively 

by sampling a source area and specifying a target. This tool enables you to copy pixels from 

surrounding areas over the unwanted particles. In the example below, the lint appearing in this 
scanned 35 millimeter slide is the perfect candidate. 
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Here's a brief drill on the steps to remove lint from your photos using the Clone Tool and our example 
as the model: 

1. First, zoom into the area that you want to work on using the Zoom Tool, and choose the Clone 
Tool (C) from the Toolbox. 

2. In the Property Bar, set the Brush Type to Normal Clone and the Nib Shape to any of the first 
12 brush styles in the selector (as shown below). This will set the brush to a medium 

feathered edge. It will also help to set your brush size just slightly larger than the lint particles 
that you wish to remove.  
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3. Choose an area that exactly matches the size, color, and tone of the area that the lint particle 
is covering. More often than not, this will be directly beside where the lint is located - either 

beside, above, or below it. This will serve as your clone source, meaning the area that you are 
going to copy over the lint particle. 

4. Adjust the size of your Clone Tool cursor to match the size of the lint particle that you wish to 
remove using the Nib Shape option in the Property Bar. The size of your cursor should be 

slightly larger than the width or height of the lint particle. 

5. To specify your clone source, hold the Clone Tool cursor over the area and Alt+click or right-
click. At this point the Clone Tool cursor is still active and movable, and a blinking cursor with 
a cross hair inside it now indicates the initial source area that you clicked (as shown below).  

 

6. Use the movable cursor to drag along the path of the lint particle. Each time you do this, the 
lint particle pixels are replaced by the area that you specified as your clone source.  

After you've experimented with removing lint from different background types, you'll develop a knack 
for the clone sources that work best. In our example below, lint particles of various lengths, angle and 

color were removed with barely a noticeable trace, resulting in a much cleaner photo. 
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Remove Noise and Compression Artifacts 
If your photo appears grainy or blotchy, it may be suffering from noise or over-compression, although 

each is caused by different phenomena. Noise is most often caused by low light exposures and/or 
using high-speed film. Over-compression, which results in degraded image quality is most often 

caused by applying too much compression when saving images in JPEG format. Below are examples of 
noise and over-compression. 

 

The most efficient way to reduce the appearance of noise is using the Tune Noise filter, accessed by 
choosing Effects > Noise > Tune Noise. The filter (shown below) is like having access to nine filters in 

a single dialog. Each noise filter type is represented by a thumbnail image of your photo with the 

effect applied once. The thumbnails in the top row are for adding noise, while those in the bottom row 
are strictly for removing noise. 
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The noise removal filter that you choose will depend on the resolution of your photo and the amount 

of noise that you want to remove. You can add or remove noise in steps by clicking the corresponding 

thumbnails. You can also incrementally back out of the effects that you have applied by clicking Undo. 
The results aren't final until you click OK to close the dialog. 

Removing noise blurs your photo, so before applying the filter it may be wise to mask the areas in 
which you wish to preserve detail. The excessive graininess in the example below was significantly 

reduced using the Median noise filter. Before the filter was applied, a mask was applied to the central 
figure. 
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Removing compression marks often requires slightly more aggressive action, depending on the 
amount of smudginess in the photo. For subtle and/or isolated smudges, I recommend using the 

Touch-up Brush Tool at a very low setting. But for heavily smudged areas (especially backgrounds) try 
the Jaggy Despeckle noise removal filter in the Tune Noise dialog. This filter specifically applies a 

blurring effect to vertical and horizontal edges seen in over-compression and is much more effective at 
removing artifacts than simply blurring the entire image. 

The example below shows how artifacts in our previous extreme compression example were 
significantly reduced using two clicks of the Jaggy Despeckle noise removal filter with the default 

settings. 

 

Correcting Blurry Pictures 
Having nice, sharp photo elements is probably the most sought-after characteristic in any photo 

project. If your pictures look fuzzy or out of focus for whatever reason, there are several quick ways 
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you can improve their appearance using Corel PHOTO-PAINT, but Tune Sharpen dialog (shown below) 
is perhaps your best choice. To open the dialog, choose Image > Correction > Tune Sharpen. 

 

This filter works much like the Tune Noise filter we looked at earlier. It enables you to sharpen your 

image in four different ways by clicking any of the thumbnails. For overall image sharpening I 
recommend using the Unsharp Mask. It enables you to apply sharpening incrementally and works by 

enhancing the edge detail without the widespread image distortion often seen in other filters. 

The out-of-focus image shown below was sharpened by clicking the Unsharp Mask thumbnail in the 
Tune Sharpen dialog three times while the Percentage and Background sliders were both set to 100 

percent. 
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Fixing Perspective Distortions 

Everything you see with your eyes features a distortion effect caused by your perspective. Simple 

perspective distortion causes distant objects to appear smaller than the ones closer to you. Your brain 
can compensate for what your eyes see, but unfortunately most cameras don't. This means photos of 

tall buildings or other large objects will include perspective distortion. 

Fortunately, you can correct this effect using options in the Perspective filter dialog. In the example 
photo below, the buildings appear slanted inwards due to a vertical perspective distortion. Using the 

Perspective filter, we can make the buildings appear straight again. You can follow these generic steps 
to correct the perspective distortion in virtually any digital photo. 
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1. Open your distorted photo in Corel PHOTO-PAINT and choose View > Rulers (Ctrl+Shift+R). If 
you're correcting for vertical distortion, drag a guideline from the vertical ruler onto your 

image and place it close to the edge of slanted building or object (as shown below). This will 
serve as reference while correcting the distortion.  

 

2. If your photo's perspective is distorted horizontally, you can drag a guideline from the 
horizontal ruler and align it close to a horizontal element in your photo. 

3. Open the Perspective filter dialog by choosing Effects > 3D Effects > Perspective. Click to No 
Pane preview, and be sure the Preview button is toggled on. This will enable you to preview 

the distortion you onscreen. For your options, choose Perspective and Best Fit (as shown 
below).  
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4. In the mapping window, you'll see a dotted line with four corners which represents the 
boundaries of your photo. To correct your photo's vertical distortion, drag the upper-right 

corner to the right slightly (as shown below) and watch how your photo preview is affected. 

Use your vertical guideline as reference and continue dragging the corner marker until the 
vertical edges in your photo are parallel with it.  

 

5. If you need to correct the horizontal perspective of your photo, perform the same operation 
but this time drag the lower-left and/or lower-right corner markers in the mapping window 

upward or downward one at a time (as shown below). Use your horizontal guideline as 
reference by aligning your photo's horizon to be parallel with it.  

 

6. As you correct the distortion, the pixels in your image will be mapped to the new shape in the 
mapping window. Before clicking OK to close the dialog and apply the changes, be sure the 

proportions in your images appear realistic and make adjustments in the mapping window to 
compensate. 

7. Since you're essentially distorting the entire photo in order to correct objects within it, the 
final result will be a non-rectangular photo. This means your photo will most likely have gaps 
around it where the canvas color shows through. To crop the image to a rectangular shape 

once again, use the Rectangle Mask Tool to define new boundaries for your image and choose 
Image > Crop > Crop to Mask.  

In our example image below, the vertical edges of the building were straightened and much of the 
distortion was removed using the Perspective filter, and the final image was cropped to a rectangular 

shape. 
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